Chiller fail

5 posts / 0 new
Last post
Canuck
Canuck's picture
Offline
Last seen: 1 month 4 days ago
Alchemist, member since
Chiller fail

Hey guys, whats up in Chicago?

So I was brewing today and everything was going really  well for a change. Then came time to chill and this happened. My copper imersion chiller sprung 3 leaks. Is this a thing? Has this happened to anyone else before the aewsomness of the CHAOS counter flow chiller that is. Ruined a 5 gal RIS as it dumped about a gallon of hose water into my RIS. I checked it before putting into the wort as I was cleaing it and noticed nothing.

Alex Dropkin
Offline
Last seen: 3 days 9 hours ago
Brewer, member since
shoulda just reboiled for a

shoulda just reboiled for a minute!!! but yeah that is strange 

Ben r.
Ben r.'s picture
Offline
Last seen: 1 day 3 hours ago
Alchemist, member since
Holy cow - did you use a

Holy cow - did you use a power washer as your water source? 

I've never seen anything like that that happen.  We've been using the same old CHAOS  copper coil again this winter - no problems at all (except all the fittings still leak as usual).  That's really bizzare. Not sure if you bought that coil or made it - but if you purchased it somewhere, I would raise a stink no matter how long its been.

Bad news about the RIS!

Jeff W
Jeff W's picture
Offline
Last seen: 1 day 20 hours ago
Alchemist, member since
Wow, that's pretty crazy!

Wow, that's pretty crazy! What's in the water up there?!

Kyle N
Kyle N's picture
Offline
Last seen: 2 days 8 hours ago
Alchemist, member since
It most likely had residual

It most likely had residual water in it and froze over the winter.